Symptom
- After upgrading to Catalog 3.0, clicking on Browse All Courses from the Find learning tile, results in No Data.
- Items are not showing in Catalog 3.0 Search.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Learning Management System
Reproducing the Issue
- Login as user
- Navigate to Learning home page
- Click on Browse All Courses
- No Data is displayed
Cause
There are two possible causes of the No Data in the Browse All Courses search:
- There is an incorrect system configuration of Catalog related settings.
- Items are not marked as "Featured","New" or "Revised" in the catalog for which the users have access to.
Resolution
To show all the Items in the catalog:
- Go to System Admin > Configuration > System Configuration > edit Catalog
- Look for catalogBrowseEnabled= and set it to false (catalogBrowseEnabled=false)
- Apply changes
Or to enable the flag items feature:
- Login as Admin > Go to Learning > Catalog (search for the affected catalog)
- Select the Items tab. There is an option to set the Flag as Featured, New & Revised.
- Select a flag from the drop down > Save
See Also
KB article - 2752876 - Hidden Refine Search in Catalog 3.0 - LMS
Keywords
SF, Success Factors, LMS, learning, No Data, Catalog 3.0, Browse All Courses, catalogBrowseEnabled, flag, Featured, New, Revised, configuration , KBA , LOD-SF-LMS-COR , LMS Core - Items, Catalog, Curricula , Problem
Product
SAP SuccessFactors Learning all versions