SAP Knowledge Base Article - Public

2408916 - EC Alerts: Rule Execution Error: No context object found to execute SET action

Symptom

Alert and Notifications are not triggered

Per initial review- the rule, workflow, employee data and job are fine

If we get the logs from business rule execution log, we see error such as: No context object found to execute SET action

Environment

Employee Central - Alerts and Notifications

Reproducing the Issue

  • Make changes to employee data and run the EC Alerts and Notification job

  • The notifications are not sent and alerts are not triggered

Cause

  1. Go to Business Rule Execution Log and you can see only the else part in the rule is failing
  2. The log says as: No context object found to do SET action

If we go through the logs, we will get to know in what context the error occured, an example log:

No context object found to execute SET action (property=alert.wfConfig, base=workPermitInfo...

In above line, the context is with alert paramter

Resolution

As per the workflows implementation guide, we are supposed to use exact parameter. This is clearly explained in article 2156278 and also in the corresponding page of the handbook.

When you add the "Alert" Parameter to the Business Rule, you must write the "Code" and "Name" correctly, in English, as exactly defined in the handbook.

It is case sensitive and hence configuring it wrong can cause this problem.

  • The correct Parameter is Alert

Name/Codes should be exactly as mentioned and matching in case and spelling

See Also

2156278 - How to set up EC Alerts and Notification using Business Rules

Keywords

No context object found to execute SET action, Alert and notification not triggered, Rule context, alert , KBA , LOD-SF-EC-ALR , Alerts & Notifications (saveAlert - EC Core only) , LOD-SF-EC , Employee Central , How To

Product

SAP SuccessFactors HCM Core 1611