SAP Knowledge Base Article - Public

2310570 - Browser Settings for Online Content/Usage of SuccessFactors Learning

Symptom

  • Users may experience issues launching or viewing online content
  • Users redirected to BizX logon page when launching content
  • API Error messages when launching content
  • Users/admins see blank page when accessing Learning

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Go to the user's Learning Plan.
  2. Try launching a course which the content is hosted in iContent.
  3. See one of the symptoms.

Cause

  • Due to IT level security, certain browsers or machines might face issues if minimum requirements to use the HXM Suite are not setup.
  • If the IT level security is too strict, this could also cause issues.

Resolution

Note: Browser related configurations and assistance with updating/managing these settings is outside the scope of Support. We suggest that you work with your IT team to make these changes at a global level.

  1. Validate the browsers are supported by accessing the HXM End User Requirements Guide.
    • Always make sure to update to the latest version whenever possible.
  2. Validate with your IT team or browser manufacturer that you meet the requirements.
    • It is important JavaScript, Cookies, and Pop-Up windows are allowed.
    • Based off the brower, these actions can differ. Links to the respective browser manufacturer help site:
  3. Clear the Cache and Cookies
  4. Trusted Sites may be required by your Organization. This is only for Windows based devices and it does have different impacts on browsers.
    • Trusted Sites is a global setting on Windows devices that uses Zones to allow/block certain actions, access, etc. if websites are not placed in it.
    1. Either use the Windows Search bar for Internet Options or press the Windows Key + R on the keyboard to bring up the Run Command. If the Run Command was used, type in inetcpl.cpl and press Enter.
    2. Go to the Security Tab > Select Trusted Sites > Press the Sites button.
    3. Add in the required URLs. It's best practice to add the domain of the URL such as "https://*.sapsf.com". Please add your BizX URL and Learning URL.
      • BizX URL can be seen in the browser navigation bar upon initial login of the system.
      • Learning URL can be seen in the browser navigation bar upon access Learning User or Learning Admin.
    4. Click on Apply.

Note: These steps are from a manual process on one computer. Work with your IT team to cascade these changes across your Organization.

See Also

KB article 2350530 - SuccessFactors Application connectivity verification to validate compatibility with Akamai Content Delivery Network (CDN)

Keywords

sf, success factors, LMS, chrome, browser, setting, popup, clear, cache, online content errors, API error, error, API, SCORM 1.2, SCORM 2004, SCORM, AICC, online, content, internet options, pop-up blocker, trusted sites, temporary files, cookies, protected mode, Your request has been denied, blank page, redirect, bizx login , KBA , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-CNT , Content , LOD-SF-LMS-PCM , iContent , How To

Product

SAP SuccessFactors Learning all versions