SAP Knowledge Base Article - Public

2300521 - How to Grant RBP Permissions Over Employee Data - EP

Symptom

  • After adding a field or portlet to the Employee Profile (Configure Employee Files), the field/portlet is not visible in the Employee Profile
  • This KB article explains how to grant RBP permissions over Employee Data

Environment

SAP SuccessFactors Employee Profile

Cause

If the field/portlet is not visible in the Employee Profile, it is likely that the logged-in user does not have permissions to view the field/portlet for the user whose Employee Profile he is accessing

Resolution

To grant permissions for the users to view/edit a field or portlet in the Employee Profile, follow the steps below:

  1. Go to Admin Center > Set User Permissions > Manage Permission Roles
  2. Select the Permission Role you would like to modify (depending on the granted and target population)
  3. Click the “Permission” button > select “Employee Data” tab > enable View and/or Edit permission for the desired Employee Profile fields or background elements > click on “Done”
  4. Click on “Save Changes”

Keywords

SF, success factors, role based permissions, EP , KBA , LOD-SF-EP , Employee Profile , Problem

Product

SAP SuccessFactors HXM Suite all versions