Symptom
When creating an Advanced Reporting query, the drop down shows 'No Realm is available' and you are not able to do anything with any of the functions on this screen.
Environment
- SuccessFactors HCM Suite
- Advanced Reporting
Reproducing the Issue
With Report Center enabled:
1. Go to Report Center and create a new Report - Canvas
2. Add a List report table component
3. Select the component and click Edit Query
4. If the Advanced Reporting tab is available, click on New. In the new query editor window that opens, the drop down will show "No Realm is available"
For instances without Report Center yet.
- Analytics - Analytics
- From the Tools section you have the option Advanced Reporting which open the Analytics Home screen.
- From the drop down 'No Realm is available' is shown and you are not able to do anything with any of the functions on this screen.
Cause
The message may be caused by back-end configuration.
Resolution
From the drop down 'No Realm is available' is shown because of the following:
- The Advanced Reporting company was not created automatically in the Analytics backend or its setup is not correct.
- The Advanced Reporting is enabled but Employee Central is not configured > The Advanced Reporting is a feature within SuccessFactors that allows users to query Employee Central data. If Employee Central is not configured the Advanced Reporting will not work.
In case you face one of the above scenarios you may approach your Implementation Partner or Customer support in order to change such backend configuration.
Keywords
No Realm is available, cannot create query, Advanced reporting not working reports error rendering list report blank empty , KBA , LOD-SF-ANA , Analytics & Reporting (Ad Hoc, YouCalc, ORD) , LOD-SF-ANA-ADV , Advanced Reporting (ODS) , Problem