SAP Knowledge Base Article - Public

2271226 - Notification Emails are not Received from Automatic Processes

Symptom

Users report that they are not receiving notification emails. These notifications are triggered from various APMs.

Environment

SAP SuccessFactors Learning

Reproducing the Issue

Run (or schedule) the APM background job for the related notifications that user's report not receiving.

Cause

There are no outgoing notifications for scheduled jobs (APMs) because the related admin account does not exist in the affected instance.

Resolution

A Learning administrator will need to add or unlock the AUTO-SCHEDULER admin user.

  1. Access the Learning Admin UI
  2. Expand System Administration > Security > Administrators
  3. Search for Admin ID AUTO-SCHEDULER - ensure that the search criteria for Status is 'Both', to include both unlocked and locked users.
    1. If there is no such admin, then it will need to be added.
    2. If the admin user is found but locked, it will need to be unlocked.
      1. To unlock AUTO-SCHEUDLER > Edit account > Uncheck "Locked" > Apply changes

To add the admin user:

  1. Access the Learning Admin UI
  2. Expand System Administration > Security > Administrators
  3. Click on Add New in the upper right corner.
  4. The admin user ID must be AUTO-SCHEDULER exactly.
    1. Ensure the domain is set to PUBLIC.
    2. Set a password.
  5. No other details need to be maintained.
  6. Click on Add.

To unlock the admin user:

  1. Access the Learning Admin UI
  2. Expand System Administration > Security > Administrators
  3. Search for Admin ID AUTO-SCHEDULER - ensure that the search criteria for Status is 'Both', to include both unlocked and locked users.
  4. Edit the account
  5. Uncheck the box for Locked.
  6. Click Apply Changes.

 

Keywords

email, mail, notifications, automatic process, issue, users, learning plan, expiration, overdue, none, send, receive, kal, kac , KBA , LOD-SF-LMS-NOT , Notifications , Problem

Product

SAP SuccessFactors Learning all versions