Symptom
Recruiting tokens appear unresolved in the body of the email received following the use of the Email job to friend functionality on the career site
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Navigate to the external career site or the internal career module and select a job
- On the right hand side of the description, select the Action: Email Job to Friend
- Populate the name and email address of the person you want to send the job to
- The message contains prepopulated information based on the configured template, including tokens
- Click send
- The recipient receives the email but the tokens present in the body of the email appear unresolved, showing as [[JOB_REQ_TITLE]] for example
Cause
In the "Email job to friend" Recruiting E-Mail Trigger, recruiting tokens are not supported, with the exception of the [[MICROSITE_LOGO]].
The token content is static. The Job Title and description (if present) are automatically populated in the title and the body of the email, along with the link to apply for the job.
You can add text to the notification using a template you created but recruiting tokens will not resolve correctly.
Resolution
This is the current system behaviour.
You can submit an enhancement request if you would like this functionality to be considered in a future release.
See Also
2090228 - How to Submit Enhancement Requests - BizX Platform
Keywords
KBA , LOD-SF-RCM , Recruiting Management , Problem