Symptom
Searching for users with special characters in the name (For example: "umlaut" character), the system does not return any results, although the user exists.
Special Characters Examples: ä ö ü Ä Ö Ü ß.
Environment
- SAP SuccessFactors HCM Core
- SAP SuccessFactors Employee Central
Cause
This issue may occur due to the following features not been enabled in provisioning:
- Enable Action Search;
- Enable Solr People Search in global head.
Resolution
To correct this issue, it is necessary to engage your Implementation Partner or open an incident with Cloud Product Support, as access to Provisioning is required.
Support and Partners:
- Login to Provisioning;
- Select "Company Settings";
- Enable the options "Enable Action Search" and "Enable Solr People Search in global head".
Now, the system will retrieve users with special characters in the name.
Please note: This will only affect the People/Action Search. When searching via Employee Search in People Profile, if an employee has an accent character in their name, this will need to be entered when completing the search, otherwise the search will not return a result for that employee.
Keywords
special character, language, search box, people search, EDU-11287 , KBA , LOD-SF-EC , Employee Central , LOD-SF-PLT , Platform Foundational Capabilities , Problem