Symptom
Shared Ad Hoc/Table report is not visible for certain users in SuccessFactors.
Environment
- SAP SuccessFactors HXM Suite
- Report Table
Reproducing the Issue
For instances without Report Center:
- Login with user A
- Go to Analytics – Ad Hoc Reports > Share a report with user B
- Proxy as user B
- Go to Analytics – Ad Hoc reports - check the shared report from the adhoc report list
- User B could not see the shared report on the list
For instances with Report Center:
- Login with user A
- Go to Reporting > Share a Table report with user B
- Proxy as user B
- Go to Reporting > My Reports
- Apply a filter for Report Type: Report - table and search for the shared report from the list
- User B could not see the shared report on the list
Cause
User B does not have permission to run a report based on the subdomain schema the report was created for.
Resolution
- Edit the Report and identify the subdomain schema used in the report
- Grant at minimum the Run Report permissions for the subdomain schema under the concerned for the affected user(s)
See Also
KBA 2322495 - How to Grant Ad Hoc Report / Report Table Permissions to Users - Report Table
Keywords
SF, success factors, PLT, platform, RPT, WF, work force, ANA, adhoc , KBA , LOD-SF-ANA-ADH , Adhoc Reports & Report Builder , LOD-SF-WFA , Workforce Analytics & Planning , Problem
Product
SAP SuccessFactors HXM Suite all versions