Symptom
Application error on accessing Employee Profile v12
Environment
SuccessFactors BIZX: Employee Profile
Reproducing the Issue
- Under Home drop-down, go to 'Employee Profile'
- Go to Profile-> application error comes
- All portlets are loaded properly but still the error comes.
Cause
There could be many reasons for the application error on Employee Profile but one of the reasons is due to invalid configuration of date field in the background portlet.
If any background portlet has start and end date columns then xml field-id of these columns should be correctly configured.
Resolution
Clients open an incident and ask Support Engineer to check below configuration in data model xml:
Invalid Configuration:
<data-field id="startDate" field-name="vfld5" max-length="999" max-file-size-KB="1000">
<data-field id="startDate" field-name="vfld6" max-length="999" max-file-size-KB="1000">
Correct Configuration:
<data-field id="startDate" field-name="startDate" max-length="999" max-file-size-KB="1000">
<data-field id="endtDate" field-name="endDate" max-length="999" max-file-size-KB="1000">
Keywords
error in Profile , KBA , LOD-SF-EP , Employee Profile , Problem