Symptom
Indeed jobs showing recruiter's email address instead of sending candidates to RMK page.
Environment
SuccessFactors Recruiting Marketing
Reproducing the Issue
While searching and applying for jobs on Indeed, some jobs are displaying recruiter's email address and not sending the applicant to RMK system.
Cause
The reason why this is occurring is because recruiter's e-mail address is listed in the job description of the job requisition.
This can happen on some but not all jobs but when that happens, it triggers what is called the "Indeed Apply" option. In this case, the candidates are given the option to apply directly to the recruiter's e-mail address rather than via the proper job URL, as was designed & delivered via our XML feeds.
Resolution
This is not something that SuccessFactors can control as this is an Indeed workflow design in their site.
The options are:
a) Remove the recruiter e-mail from the job description;
b) Address the issue with Indeed to request that they do not have the Indeed Apply option with sending candidates direct to e-mail.
Keywords
KBA , LOD-SF-RMK , Recruiting Marketing , How To