Symptom
No deployment location or server is available when attempting to import / upload content
Environment
SAP SuccessFactors Learning Management System - LMS
Reproducing the Issue
- Logon to LMS Admin
- Navigate to Content > Tools > Import Content
- Select an Action to add content & click Next
- Select a file to Import content to the content server
- Note that the option to select a deployment location is not displayed
Cause
- The admin user does not have the correct permissions to access deploy content to server
- The deployment location has been de-activated or deleted
Resolution
Ensure Admin User has needed permissions:
- Logon to LMS Admin
- Navigate to System Admin > Security > Role Management
- Search for a Role the Admin belongs to
- Navigate to "Workflows" tab on the left
- Expand Content and look for the workflow "Access Deploy Content To Server"
- If it is not there, add it
- If it is there, check the domain restriction - does it allow access to the domain the Deployment Location belongs to?
- More information on permissions can be found in our User Assistance Documentation:
https://help.sap.com/hr_learning
To add a deployment location:
- Logon to LMS Admin
- Navigate to Content > Deployment Locations
- Click Add New
- Enter server information
- Save the changes
Keywords
SF SuccessFactors LMS Learning workflow, access, add, view, content server, deployment location, tools, feature, functionality, sftp, kal, kac , KBA , LOD-SF-LMS-CON , Connectors , Problem
Product
SuccessFactors HCM Core 1508