Symptom
When trying to add a password protected file to a ticket, system does not allow you to do so.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Service work centre.
- Go to the Tickets view.
- Open ticket XYZ (XYZ represents the ID of the ticket).
- Go to the Attachments tab.
- Select Add > Local File.
- Select password protected / encrypted file.
Error message: "Password-protected compressed file" is shown.
Cause
The error message is shown because the virus scan is not able to scan the file content when it is password protected and, therefore, will not allow for the file to be uploaded.
Resolution
This is the expected system behavior which cannot be changed due to security reasons and given our security policy. They system has Virus Scan that cannot check password protected / encrypted files and therefore it blocks this types of attachment.
In order to adjust this behavior, you may raise an incident so our Operations team can proceed to disable the Virus Scan for password protected files. In the incident, you must acknowledge you are aware that changing the virus scanner settings upon your request will mean that the virus scanner will only raise warnings in case it is not able to scan a file (e.g. due to encryption), allowing the file to be uploaded into C4C. Furthermore, to keep the security level, files need to be scanned before encryption and the parties downloading files should have on-access virus protection active.
As an alternative, you may remove the password protection from the file.
See Also
2584828 - Password Protected Microsoft Office Files Cannot Be Uploaded
Keywords
Attachment, File, Password Protected, Encrypted , KBA , password protected , attachment , SRD-CC-FED , Feeds , How To