Symptom
When attempting to approve a new hire or rehire workflow for a specific user in Employee Central, the following error is returned on the final step of the workflow:
Cause
The cause of the problem is a data issue for this specific user. The logs show the following error: ORA-00001: unique constraint (SFV4_STOCKPM5725.UC_EMP_PHONE_INFO_KEY) violated
Resolution
To avoid this error and complete the new hire or rehire for this user, use the following steps:
1.) Go to personal information for this user and delete the existing phone information records
2.) Now approve the new hire or rehire workflow for the same user
3.) The workflow should be approved without error
Keywords
EC; rehire workflow error; wrapped exception; could not execute JDBC batch update , KBA , LOD-SF-EC , Employee Central , How To