Symptom
When users try to access LMS (Learning) from BizX in an integrated environment via Safari browser (Mobile or Desktop), they might get the following Validation Error:
Failed to authenticate the SAML response. If this keeps happening please contact the administrator.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HXM Suite
- SAP SuccessFactors Learning
Cause
This error message is related to the Browser cookies that are being blocked.
Resolution
To fix the issue in Safari, please try the below steps:
- Please clear the cache and cookies first in the browser
- Try changing the Setting > Safari > Privacy & Security > Block Cookies > Never
- Also check the setting 'Prevent cross-site tracking' to disable it if the error persists.
For Mobile:
Turn off the following settings:
- 'Prevent Cross-Site Tracking'
- 'Block All Cookies'.
Keywords
SAP, SuccessFactors, Learning, LMS, BizX, SAML Response, error, Failed to Authenticate, Safari browser, SAML error, if this keeps happening please contact the administrator, apple, mobile , KBA , LOD-SF-LMS-INT , Integrations with BizX , LOD-SF-LMS , Learning Management System , Problem