SAP Knowledge Base Article - Public

2181354 - Error when importing Picklist: Picklist already in use: [picklist ID]

Symptom

When trying to import picklist records to the master picklist you receive this error during import:

"Error communicating with the server. Please contact customer support.
Picklist already in use: [picklist id]"

Environment

SuccessFactors BizX
SuccessFactors Employee Central

Reproducing the Issue

  1. Create a picklist import file with new picklist items
  2. The picklistID for these new items already exists but the external_code is unique
  3. Select Yes for the option "Are all Picklist items new?"

Cause

The items being imported are new, but they are being added to an existing PicklistID. 

The option "Are all Picklist items new?" should only be set to Yes if the Picklist ID does not currently exist in the picklist.

Resolution

  1. Select No for "Are all Picklist items new?".
  2. The OptionID for each picklist item being imported should be left blank so the system will recognize them as new. 

Keywords

KBA , LOD-SF-EC , Employee Central , Problem

Product

SuccessFactors HCM Suite 1502 ; SuccessFactors HCM Suite 1505