SAP Knowledge Base Article - Public

2138823 - User Data File (UDF) or Employee Import: General Error Codes - PLT

Symptom

  • When performing a People Import via Admin Tools a General Error code is received.
  • E-mail notification from the Associate Import scheduled job with a General error.
  • UDF import unsuccessful: some users show an error code.
  • When any of the above happens, an error code that can assist in determining the issue is generated.

Environment

SAP SuccessFactors HXM Suite

Reproducing the Issue

Example errors will look like:

Failed to add/update user USERNAME. General Error with error code - -XX"

Cause

  • The cause of the problem is related to the error code.
  • See below for an explanation of the codes:
    • USEREJB_OK = 0;
    • USEREJB_ERROR = -1;
    • INVALID_LOGIN = -2;
    • INVALID_PASSWORD = -5;
    • INVALID_USERID = -6;
    • INVALID_MANAGER_ID = -7;
    • INVALID_HR_ID = -8;
    • USERBEAN_IS_NULL = -9;
    • MANAGER_CYCLE_DETECTED = -10;
    • INVALID_USERNAME = -11;
    • DUPLICATE_USERNAME = -12;
    • PASSWORD_EXPIRED = -13;
    • USER_NOT_FOUND = -14;
    • NO_LOGIN_PERMISSION = -15;
    • ACCOUNT_LOCKED = -16;
    • REQUIRED_COLUMN_MISSING = -17;
    • PROXY_ALREADY_EXISTS = -18;
    • PROXY_NOT_EXISTS = -19;
    • INVALID_MATRIX_MANAGER_ID = -20;
    • INVALID_PROXY_ID = -21;
    • INVALID_CUSTOM_MANAGER_ID = -22;
    • INVALID_SECOND_MANAGER_ID = -23;
    • SECOND_MANAGER_CYCLE_DETECTED = -24;
    • ACCOUNT_VALIDATION_NEEDED = -25;
    • USER_LIMIT_VIOLATION = -26;
    • USER_IS_PURGED = -27;
    • EXTERNAL_NOT_SUPPORTED = -28;
    • FOUND_USERACCOUNT_FOR_PURGED = -29;
    • FOUND_PERSON_FOR_PURGED = -30;
    • DUPLICATE_ASSIGNMENT_ID_EXTERNAL = -31
    • ASSIGNMENT_ID_EXTERNAL_NOT_SUPPORTED = -32
    • USER_ID_AND_ASSIGNMENT_ID_EXTERNAL_NOT_SAME = -33

Resolution

  • Some error codes are self-explanatory. Review the data being imported also review 2088752 - Employee Import Email Notification System Error Codes and Messages – Platform - which provides further details on the error codes encountered. 
  • Other error codes may require additonal search in the Knowledge Base. It is recommend to use new found cause as a search term/keyword. You will learn more about the expected data in an Associate Import.
  • If the KB search was unsuccessful, create a Support Incident, referencing the specific error code. Remember to provide as many details as possible such as:
    • Job Name
    • Date and Time of Execution
    • Date and Time of Received Notification
    • InstanceID
    • Timestamp

See Also

3051283 - H1 2021 - Employee Import Email Notification Changes

2449342 - Troubleshooting Employee Import issues - Guided Answer

2089382 - User Import Errors - Duplicate Username or Username has already been taken by a soft purged user - Platform

2088752 - Employee Import Email Notification System Error Codes and Messages – Platform

Keywords

colleague, People, SF Success Factors PLT , employee import , KBA , LOD-SF-PLT-UIM , Employee Import Issues , LOD-SF-PLT , Platform Foundational Capabilities , Problem

Product

SAP SuccessFactors HXM Suite all versions