Symptom
Some or all of the calibration sessions are throwing an error of: “There was an error retrieving data. Please contact support”
Environment
SAP SuccessFactors Calibration
Reproducing the Issue
- Log ito the instance;
- Go to Calibratio module;
- Open one of your Calibration Sessions;
- The error message below shows up.
Cause
The RBP settings are not set correctly or by a defined "Level id" with no Icon specified in Matrix Classifier XML.
Resolution
In the RBP Role, for the particular role, target population permission has been enabled only for particular users.
We have to grant permission for EVERYONE because this can give access to search for everyone, so that all the users can access calibration.
If caused by incorrectly defined Level ID and Icon configuration
Partners/Support Only. If no access to Provisioning, please contact support.
There are 2 possible action plans to take in Matrix Classifier Configuration in Provisioning:
- Remove the Level ID script with missing icon configuration
- Define an Icon script. Example script: <Icon alt="" title="Key Position" url="/ui/uicore/img/org_icons/key1.jpg"/>
See Also
Keywords
calibration session error, calibration launch error, there was an error retrieving data , KBA , csg_q , LOD-SF-CAL , Calibration Module , Problem