SAP Knowledge Base Article - Preview

1953229 - Summary - Rescue obsolete variants after the upgrade

Symptom

After an upgrade(including sp/sps upgrade), variants may be characterized as obsolete. So you need do re-adjustment for rescuing the obsolete variants.

the following problems can occur:

1.) When you start a report with a variant, the following error messages are generated

     DB 263 Import error - obsolete variant
or
     DB 634 Variant & of program & is not the current version
or
    runtime error
    "Error occurred importing object xxxxxx"

2.) When you try to adjust the variant, the following error message is generated

     DB 269 Error when generating program & & & &.
           Only one length specification from ... to ... is allowed for type xx


Read more...

Environment

ABAP System.

Product

SAP NetWeaver all versions

Keywords

KBA , BC-ABA-TO , Logical Database, Selection Screens, Selection Variants , How To

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP ONE Support launchpad (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.